WordPress 5.2正式版Jaco已经发布,建议更新升级

转载 boke112  2019-05-09 09:30  阅读 147 次 评论 0 条 百度已收录

WordPress 的 5.2 版本,名为“Jaco”,以纪念着名和革命性的爵士贝司手 Jaco Pastorius,可在 WordPress 仪表板中下载或更新(PS:或点此直接下载)。如果出现问题,此更新中的新功能可以比以往更轻松地修复您的网站。还有更强大的工具可用于识别和修复配置问题和致命错误。无论您是帮助客户的开发人员还是您自己管理网站,这些工具都可以帮助您在需要时获得正确的信息。

遇见WordPress

现场健康检查

基于 5.1 中引入的站点运行状况功能,此版本添加了两个新页面以帮助调试常见配置问题。它还增加了开发人员可以为站点维护人员提供调试信息的空间。

PHP 错误保护

这种以管理员为中心的更新可让您安全地修复或管理致命错误,而无需开发人员时间。它具有更好的处理所谓的“死亡白屏”,以及一种进入恢复模式的方法,它可以暂停导致错误的插件或主题。

对每个人的改进

  • 辅助功能更新许多变化协同工作,以改善使用屏幕阅读器和其他辅助技术的人的上下文感知和键盘导航流程。
  • 新的仪表板图标十三个新图标,包括 Instagram,BuddyPress 的一套图标,以及全球包含的旋转地球图标。在仪表板中找到它们并享受一些乐趣!
  • 插件兼容性检查WordPress 现在将自动确定您的网站的 PHP 版本是否与已安装的插件兼容。如果插件需要比您的网站当前使用的更高版本的 PHP,WordPress 将不允许您激活它,以防止潜在的兼容性错误。

开发者的福利

  • PHP Version Bump支持的最低 PHP 版本现在为 5.6.20。从 WordPress 5.2 *开始,主题和插件可以安全地利用命名空间,匿名函数等等!
  • 隐私更新新的主题页面模板,条件函数和两个 CSS 类使得隐私策略页面的设计和自定义变得更加容易。
  • 新的body 钩子5.2 引入了一个 wp_body_open 钩子,它允许主题支持在<body>元素的开头注入代码。
  • 构建 JavaScript通过在 wordpress / scripts 包中添加 webpack 和 Babel 配置,开发人员不必担心设置复杂的构建工具来编写现代 JavaScript。
注意

如果您运行的是旧版本的 PHP(小于 5.6.20),请在安装 WordPress 5.2 版本之前先行更新升级 PHP,最起码要在 PHP 5.6.20 及以上的版本。

WordPress 5.2 正式版本已经推送更新,各位 WordPress 站长可以直接在网站后台直接更新即可。或者直接在此点击下载 WordPress 5.2 版本其他 WordPress 版本

更多详情请移步英文原文:https://wordpress.org/news/2019/05/jaco/

本文地址:https://www.ezliushao.com/151.html
加入我们:请加入刘少技术博客交流群:扫描二维码刘少技术博客的QQ交流群 | 浪子丶刘少 QQ:1150110267(注:微信暂停添加好友)
温馨提示:文章内容系作者个人观点,不代表刘少技术博客对观点赞同或支持。
版权声明:本文为转载文章,来源于 boke112 ,版权归原作者所有,欢迎分享本文,转载请保留出处!

发表评论


表情